Bug #17257

Mac Mini 2018 kernel panic

Added by numbat 2019-11-25 11:34:08 . Updated 2019-12-14 09:25:01 .

Hardware support
Target version:
Start date:
Due date:
% Done:


Feature Branch:
Type of work:

Affected tool:
Deliverable for:


The user says this Mac Mini worked fine with Tails 3. It now crashes with Tails 4 (see attached image) and does the same with Debian Live (Buster).




#1 Updated by numbat 2019-12-02 08:51:29

A user has reported the same issue with a MacBook pro 15,4.

The user has tried, at Grub:



or removing:

removing "live-media=removable"

With no change.

#2 Updated by numbat 2019-12-02 09:01:38

A user sent us this link which may contain some hints, but no solution yet:

#3 Updated by goupille 2019-12-06 17:50:25

  • Status changed from New to Confirmed
  • Assignee set to intrigeri

another mac user reported a kernel panic with tails 4.1 with two different mac (one is a macbook pro 9,1 and the other one is not described). this user says that tails 4.0 worked perfectly on those computers.

Bug report: 6c589ea7443b70b3592ec58f3f8137ca

#4 Updated by goupille 2019-12-06 17:53:05

and I just noticed that the kernel panic message is not the same so it might not be related :

[    1.991319] Call Trace:
[    1.991342]  dump_stack+0x5c/0x80
[    1.991365]  panic+0x101/0x2d7
[    1.991388]  mount_block_root+0x2c4/0x2e8
[    1.991415]  prepare_namespace+0x136/0x16c
[    1.991441]  kernel_init_freeable+0x1ff/0x20a
[    1.991468]  ? rest_init+0xaa/0xaa
[    1.991491]  kernel_init+0xa/0x106
[    1.991512]  ret_from_fork+0x35/0x40
[    1.991569] Kernel Offset: 0x10400000 from 0xffffffff81000000
(relocation range: 0xffffffff80000000-0xffffffffbfffffff)
[    1.991633] ---[ end Kernel panic - not syncing: VFS: Unable to
mount root fs on unknown-block(0,0) ]---

#5 Updated by goupille 2019-12-06 18:39:46

a second user reported the Kernel panic - not syncing: VFS: Unable to
mount root fs on unknown-block(0,0) error so I opened another ticket (Bug #17320)

#6 Updated by goupille 2019-12-09 16:20:49

we received another report for this kernel panic, on a MacBook Pro 2019

#7 Updated by intrigeri 2019-12-14 09:07:22

  • related to Bug #17320: Kernel Panic with some Macbook Pro added

#8 Updated by intrigeri 2019-12-14 09:08:34

  • related to deleted (Bug #17320: Kernel Panic with some Macbook Pro)

#9 Updated by intrigeri 2019-12-14 09:25:01

  • Assignee changed from intrigeri to numbat

Indeed, this looks like a different problem than Bug #17320, because Bug #17320 does not affect 4.0 (while this one does), and this problem affects pristine Debian, while Bug #17320 is Tails-specific.

Please ask the affected users to trying the following sets of boot options in syslinux:

  • noapic
  • noapic efi=noruntime
  • noapic efi=old_map
  • noapic efi=nochunk
  • noefi

Note (mostly to myself): the kernel error happens in the get_cert_list function from security/integrity/platform_certs/load_uefi.c, which reads extracts a list of certificates from an EFI variable. I’m a bit surprised this code path is triggered at all on a system that does not support Secure Boot.