Bug #17228

Tails 4.0 greeter loads a second time when admin password added

Added by adamantium 2019-11-13 18:47:53 . Updated 2020-04-15 06:02:27 .

Hardware support
Target version:
Start date:
Due date:
% Done:


Feature Branch:
Type of work:

Affected tool:
Welcome Screen
Deliverable for:


So I decide I want to try using the mumble scripts Tails recently linked to [many thanks], and part of the instructions are booting to tails with an admin password added. Ive occasionally done this before, not a big deal at all.

What I did:
Boot Tails 4.0, when greeter appears click additional options, add admin password, enter an admin password, click start tails.

What happened:
Greeter closes like normal, but rather than the normal tails desktop, tails greeter appears again. This could produce concerns that the Tails USB is compromised and is harvesting passwords/data.

I tried adding admin password both with and without persistence password entered, but it booted to Tails Greeter a second time in both cases rather than the tails desktop. When I entered the persistence password, then added admin PW and clicked start tails, it closed tails greeter as usual. But it launched tails greeter the second time, and I saw it had CONNECTED TO MY WIFI BY NAME which had previously been stored in persistence. So obviously if it knows the password for my router, persistence has indeed been accessed. I’ve NEVER seen wifi connected during the Tails Greeter screen before. But then, it has never launched a second time either. When booting Tails without adding an admin password, it loads normally (obviously I have to boot tails to send this bug report).


Related issues

Related to Tails - Bug #17199: Regression with some AMD GPU + Intel HD 4000 graphics (Ivy Bridge) Confirmed


#1 Updated by kdr4 2019-11-16 08:38:02

Purely FYI: I’ve booted Tails 4.0 with the Admin password several times, always with persistence, and not experienced this issue. This is a Tails 4.0 bootable USB that started as a Tails 4.0~beta1 tester, was updated to 4.0~rc1 and finally manually upgraded to 4.0, if that helps.

#2 Updated by intrigeri 2019-11-22 11:44:36

  • related to Bug #17199: Regression with some AMD GPU + Intel HD 4000 graphics (Ivy Bridge) added

#3 Updated by intrigeri 2019-11-22 11:46:11

  • Category set to Hardware support
  • Status changed from New to Confirmed
  • Type of work changed from Security Audit to Code

I believe this is the same problem as Bug #17199: the fact NM connects to the network is consistent with the hunch I have there.

#4 Updated by adamantium 2019-11-28 05:09:54

An update:

On the same computer, I tried booting tails tonight, with a few similar but not the exact same errors.

Scenario one:
Try to add both admin password and unlock persistence with password. Result: Screen goes permanently black, and Tails desktop never appears (it usually appears within 10-15 seconds of clicking “Start Tails” on the tails greeter). I waited well over a minute before hitting the power button (not pressing/holding for 4 seconds). The normal-for-tails “Something something Radeon failed” in plaintext at the top left of the screen appeared, and the system powered off.

Scenario two:
Try to boot with just adding admin password (not unlocking persistence). Result: Exact same permanent black screen after clicking “Start Tails”. Same results of hitting the power button as scenario one as well.

Scenario three:
Try to boot tails with only unlocking persistence with password. Result: Tails greeter disappears leaving just a blue screen background with various info at the top right of the screen. Tails Greeter reappears a second time!!! I see the icon at the top right that Tails is connecting to my wifi, then that it successfully connected to my wifi. I at this time just click “Start Tails” without (again) entering my persistence password. And it all goes to the permanent black screen of death, same as scenarios 1 and 2.

Scenario four (success):
Try to boot tails with unlocking persistence, but clicking “Start Tails” while persistence is still unlocking, but has not displayed “persistence unlocked”. Result: Tails boots normally, and I can log into redmine and report these errors.

Does anyone have any more speculation on what might be causing these strange errors?

#5 Updated by adamantium 2019-12-11 06:51:04

Ongoing Tails Greeter related shenanigans:

Try to boot Tails 4.1 with unlocking persistence, click start tails. Tails greeter reappears, along with logo that Tails connected to my wifi. I skip reentry of password, and just click start tails (again). Desktop appears, but under the menu, there is no mention of wifi (no menu entries at all, no connect/disconnect/list networks etc). It’s as if the wifi adapter wasn’t installed on the computer. But I did get a “Tails must synchronize clock” style message (same as usual for boot, suggesting some connection to internet), but the onion circuits app never turned into the onion (no circuits ever formed). Went to control panel, no options appear for wireless networking.

I could list more scenarios, but suffice to say it is becomming very difficult for me to boot to Tails at all from Tails 4.1. It seemed like something broke with the update to 4.0. Please continue to investigate. Is there any helpful additional info I could provide to help with the troubleshooting?

Any guesses as to what’s going on? Thanks for your help everybody.

#6 Updated by intrigeri 2020-03-26 11:53:41

  • Status changed from Confirmed to In Progress

Applied in changeset commit:tails|9919ae5e4f33114bb61fd0a74450aa7872f2d5c2.

#7 Updated by intrigeri 2020-03-26 12:01:05

  • Status changed from In Progress to Confirmed
  • Assignee set to adamantium

Could you please try adding xorg-driver=modesetting to the boot options ?

#8 Updated by intrigeri 2020-03-26 12:42:52

  • Feature Branch set to bugfix/17199-17228-udevadm-trigger-vs-dual-gpu+force-all-tests

#9 Updated by intrigeri 2020-03-26 19:43:46


I have a branch that might fix the “return to Greeter when clicking the Start Tails button” problem, that we’ve seen reported so far on a couple Intel+AMD dual-GPU systems (here + Bug #17199).

Could you please try https://nightly.tails.boum.org/build_Tails_ISO_bugfix-17199-17228-udevadm-trigger-vs-dual-gpu-force-all-tests/lastSuccessful/archive/build-artifacts/ ?

#10 Updated by intrigeri 2020-04-15 06:02:27

  • Affected tool changed from Greeter to Welcome Screen