Feature #11706

Test /install/debian/usb in Debian Stretch

Added by sajolida 2016-08-24 06:42:07 . Updated 2017-04-25 19:36:07 .

Target version:
Start date:
Due date:
% Done:


Feature Branch:
Type of work:
End-user documentation

Affected tool:
Installation Assistant
Deliverable for:


And create a ticket for the next one :)



Related issues

Related to Tails - Bug #11110: Document alternative Synaptic dialog with software-properties-gtk Resolved 2016-02-12
Related to Tails - Feature #15736: Test /install/debian/usb on Linux Mint 20 Rejected 2018-07-17


#1 Updated by sajolida 2016-08-24 06:43:29

  • Description updated
  • Category set to Installation

#2 Updated by spriver 2016-08-30 00:29:35

This worked out for me today (except the verification with DAVE since it’s a nightly). Booting from USB went fine with my ‘normal’ USB stick I’m using for tests, but booting with a SanDisk Cruzer 32GB seems to work partially, it leads to a screen displaying ’’ and a busybox shell and the error ‘(initramfs) Unable to find a medium containing a live file system’. (after showing the three dots while booting for a while, boot option live-media=removable leads to the same result). Error also occurs when installation is done via the Tails Installer in Tails itself.

#3 Updated by sajolida 2016-08-30 05:38:14

It’s really cool that you did some early testing of that so we can discard bugs early. Stretch is still bound to evolve so we’ll have to test again the whole thing after the freeze in Debian. We can do this again in November maybe?

Regarding the error on the SanDisk Cruzer 32GB, it looks like a problem with the USB (either a weird model or a broken stick). I promised myself to never by SanDisk ever again!

#4 Updated by Entriel 2017-01-15 22:48:40

I believe this may already be fixed, I use SanDisk Extreme 32GB and deleting “live-media=removable” from kernel arguments is enough for it to work(It is configured, on hardware level, as a hard disk instead of a removable device because of some windows 8 compatibility agreement thing).

Sadly I have other hardware problems too, but you can see here (https://labs.riseup.net/code/issues/11831), that the problem probably is not occurring anymore, at least not for SanDisk Extreme 32GB.

#5 Updated by intrigeri 2017-03-17 12:54:59

  • Priority changed from Normal to Elevated

#6 Updated by spriver 2017-03-19 19:54:35

Installation in Debian Stretch on a USB stick works fine. The only thing that needs to be changed a bit is the section “Install Tails Installer”, Synaptic now uses software-properties-gtk for managing apt sources (the other parts of Synaptic remained the same).

See the attached screenshots for the workflow. Basically it is:

  • Make sure that you are connected to the Internet.
  • Start Synaptic package manager.

Changed steps:

  • Choose Settings ▸ Repositories.
  • In the “Software & Updates” dialog, click on the tab “Other Software”.
  • Click on the button “Add…”.
  • Copy & paste the following to the field “APT line”: deb http://ftp.de.debian.org/debian/ jessie-backports main
  • Confirm by clicking on “Add Source”.
  • Click on the button “Close”.

From now on it’s the same procedure as it’s in Jessie:

  • In the confirmation dialog, click Reload and wait for the download of the package information to finish.
  • etc…

The remaining steps are the same as before, this is also the case for everything that is done with the Tails Installer.
I’m not (yet) familiar with the organization of the backports repository, so far it’s needed to use jessie-backports (I don’t know when tails-installer will be in stretch-backports, neither when the repo will be available itself).

#7 Updated by spriver 2017-03-19 20:00:33

I created Bug #12387 as a subtask of Feature #11916 for updating the doc. I’m wondering if this ticket can be closed then?

#8 Updated by spriver 2017-03-19 20:01:06

  • related to Bug #12387: Update doc for Tails Installer in Debian Stretch added

#9 Updated by intrigeri 2017-04-18 16:00:11

  • related to deleted (Bug #12387: Update doc for Tails Installer in Debian Stretch)

#10 Updated by intrigeri 2017-04-18 16:01:11

  • related to Bug #11110: Document alternative Synaptic dialog with software-properties-gtk added

#11 Updated by sajolida 2017-04-25 19:36:07

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)

So cool you did all these tests (twice!). So yes, we can close this ticket now and work on updating the doc in Bug #11110.

#12 Updated by Anonymous 2018-08-16 10:37:34

  • related to Feature #15736: Test /install/debian/usb on Linux Mint 20 added