Bug #10932

Disks cannot open local harddrive LVM (as Disk Utility did)

Added by emmapeel 2016-01-13 17:50:58 . Updated 2016-02-05 14:09:50 .

Target version:
Start date:
Due date:
% Done:


Feature Branch:
Type of work:

Affected tool:
Deliverable for:


Booting on a Debian laptop with LVM LUKS it is not possible anymore to access the contents of the disk with Disks, the application that replaces Disk Utility.

Steps to reproduce:

- Boot Tails 2.0beta1 on a laptop with Debian LVM.
- Try to open the local hard drive

The Disks application allows me to Unlock the device, but then I get no ‘Play button’ to mount it.

Desired result:

Being able to mount it like in Tails 1.8.2 and before.


Related issues

Blocks Tails - Bug #8045: Update path to GNOME Disks for Jessie Resolved 2014-10-09


#1 Updated by spriver 2016-01-14 09:38:11

I reproduced the bug and tried to find out what is happening. The unlocking of the device with Disks seems to be without any errors - in /var/log/ctl there’s a mesage that the parition was succesfully unlocked. I tried also to unlock my LVM’ed SSD with Nautilus and got the error “Unable to access ”120GB Encrypted" The unlocked device does not have a recognizable file system". I don’t have any more ideas. Unlocking and mounting of encrypted USB sticks works without any problems.

#2 Updated by sajolida 2016-01-14 11:13:50

  • Assignee set to spriver
  • QA Check set to Info Needed

Yeah, that’s a pain. I think that Disks removed the opening/closing of LVM volumes for some reason. If you want to further work on this, maybe you could:

1. Investigate whether there are bugs about this on the GNOME bug tracker. I’m sure more people complained about it.
2. Maybe we should document executing `vgchange -ay` in a root terminal to activate the volume group. Then you can see the partitions in Disks.

And if you don’t want to work on this, I’m fine doing it :)

#3 Updated by emmapeel 2016-01-14 18:25:39

I confirm that I can mount it if I do `vgchange -ay` on a root terminal after unlocking the volume in Disks

#4 Updated by spriver 2016-01-15 19:02:02

How should we proceed here? I couldn’t find any bug in a trice for now. Is there a doc page that needs an update then?

#5 Updated by sajolida 2016-01-16 16:03:52

At least the last note on https://tails.boum.org/doc/encryption_and_privacy/your_data_wont_be_saved_unless_explicitly_asked/ would then need to be updated. Marking this as a subtask of Feature #7584.

It’s somehow a corner case and I’m not sure we can do better than documenting `vgchange -ay` in this same note.

I assigned this to you because you are working on Disks in Jessie. But feel free to assign this to me if you prefer.

#6 Updated by sajolida 2016-02-03 18:53:31

  • Assignee changed from spriver to sajolida

#7 Updated by sajolida 2016-02-03 19:39:22

  • Assignee changed from sajolida to spriver
  • Target version set to Tails_2.2
  • QA Check changed from Info Needed to Ready for QA
  • Feature Branch set to doc/10932-disks-vs-lvm

Ready for review!

#8 Updated by sajolida 2016-02-04 15:02:44

  • blocks Bug #8045: Update path to GNOME Disks for Jessie added

#9 Updated by spriver 2016-02-05 08:20:41

  • Assignee changed from spriver to sajolida
  • QA Check changed from Ready for QA to Pass

I’ve reviewed the changes, for me they seem to be good (:

#10 Updated by sajolida 2016-02-05 14:09:16

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Applied in changeset commit:06c2ebde45f3172ff625d4492a86ddc5926c18eb.

#11 Updated by sajolida 2016-02-05 14:09:50

  • Assignee deleted (sajolida)
  • QA Check deleted (Pass)